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GuestCentric provides a digital marketing system that
makes it easy for hotels to connect to their customers
on all digital platforms. GuestCentric's cloud software
provides hotels with an easy-to-use system to pbuild
and defend their brands, lower booking costs and
drive better business decisions regarding their digital
presence. All in a simple and easy package.

One of the key factors of this simplicity and flexibility
IS inserting and customizing our booking widget. In
this document we will show you, through a number
of steps and code examples, how to implement our
booking widget on your website and how to change
its appearance to fit your design and your needs.
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step 1. log in to your backend.
https://login-emea@l.guestcentric.net/

step 2. go to Setup area and select “External Booking Gadget”.
This field shows your domain in the several languages in which is
translates.
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step 3. select the domain and click “Open”,
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8006 Booking Gadget Preview )
https://hotel-emea0l.guestcentric.net/previewBG.v01.php?api=5669ccf5017151d7ee470ab10628a80b&s=default&l=en_US&p=horizontal&b... &

Copy the following code block into every page where you want to place the booking
gadget

<div class='gcBookingGadget'></div>
<script type="text/javascript' src="https://secure.guestcentric.net/api/bg/?
apikey=5669ccf5017151d7ee470ab10628a80b&s=default&l=en_US'> </script>

Preview of the booking gadget layout

BEST AVAILABLE RATE Check-in [2014/08/14 Nr. of nights [ 25l

<div cl gcBookingGadget

<script type='text/javascript'src="https://secure.guestcentric.net/api/bg
/?apikey=a9c487135064d48f26ef1fc773f810db&s=default&l
=pt_PT'></script>
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You can customize it your own way.
We give you one example. Explore it.

The preview copied script renders this html code:

<div class=“bookingGadget”>
<div id=“shbg” class=“testing gcBooking horizontal
gc_sh” style=“visibility:hidden;”>
<form id=“shbgshortHandCheckRatesform”
method=“POST” class=“gc_horizontalSh”>
<div class=“shortHandTitle”>Best
Available Rate</div>
<div id=“shbgshortHandDate”
class=“shortHandDate”>
<div class=“checkinLabel”>Check-
in</div>
<div id=“shbgshortHandCalendarsS
hell”class=“shortHandCalendarSh
ell”>
<input id=“shbgstartDay”
class=“startDay”name=“star
tDay”’value=“2014/08/13">
<div id=“shbgshortHandCale
ndarIcon”class=“shortHandC
alendarIcon”></div>
</div>
</div>
<div id=“shbgshortHandNrNights”
class=“shortHandNrNights”>
<div class=“shortHandNrNightsLa
bel”>Nr. of nights</div>
<span class="yui-button yuk-
menu-button”id=“shbgnrNights”>
<span class=“first-child”>
<button type=“button”
tabindex=“0"”id=“shbg
nrNights-button”>2</
button>
</span>
</span>
</div>
<div id=“shbgshortHandButton”class=“s
hortHandButton™>
<button id=*“shbgshortHandCheckR
ates”class=“shortHandCheckRates
”name=“shortHandCheckRates”>Bo
ok Online</button>
</div>
</form>
</div>
</div>



CSS tips

CSS reads top-down, therefore any CSS loaded after the default CSS file or any style
added lower in the code should override the default styles

References:

http://www.w3schools.com/cssref/css_selectors.asp
http://www.w3.0rg/TR/CSS2/cascade.html
http://www.smashingmagazine.com/2010/04/07/css-specificity-and-
inheritance/

If something isn't taking effect it's because there's some other code overriding it. Use
an element inspector such as Webkit Dev Tools or Firebug to see what styles are being
applied and how.

Try to avoid the use of !important as much as possible. http://css-tricks.com/
when-using-important-is-the-right-choice/

In the example below you can see the several classes that are intended to apply. You just
need to use those with the properties that you want to change. All the others still appear
by default.

.bookingGadget {
clear: both;
position: relative;
z-index: 100;
margin-bottom: 230px;
}

.bookingGadget .gc_sh .gc_horizontalSh {
padding: 0;
width: auto;

}

.bookingGadget .gc_sh .gc_horizontalSh .shortHandTitle {
font-size: 14px;
color: #7e8487;
font-family: "GothamBold";
font-weight: normal;
margin: 0;
padding: 5px ©;
border: none;
border-bottom: 1px solid #d6dbde;
width: 100%;
text-align: left;
line-height: 25px;
}

.bookingGadget .gc_sh .gc_horizontalSh .shortHandDate {
margin: 5px @ 10px;
padding: 0;
width: 50%;



.bookingGadget .gc_sh .gc_horizontalSh .checkinLabel,
.bookingGadget .gc_sh .gc_horizontalSh .shortHandNrNightsLabel {

float: left;
width: 100%;
font-size: 10px;
color: #7e8487;
text-align: left;
font-weight: normal;
margin: 0;
line-height: 16px;

}

.bookingGadget .gc_sh .startDay {

border: none;

background: #FFFFFF;

height: 19px;

width: 65px;

padding: ©px 8px;

margin: Opx;

line-height: 19px;
text-align: center;

color: #000;

}

.bookingGadget .gc_sh .gc_horizontalSh .yui-calcontainer {

border: none;
border-radius: 3px;
-moz-border-radius: 3px;
-webkit-border-radius: 3px;

box-shadow: @px @px 5px rgba(e, 0, 0, 0.5);

padding: 6px;
}

.bookingGadget .gc_sh .gc_horizontalSh .shortHandNrNights {

margin: 5px © 10px;
padding: ©;
width: 50%;

}

.bookingGadget .gc_sh .yuimenu 1i {
line-height: 16px;
text-align: center;

}

.bookingGadget .gc_sh .gc_horizontalSh .shortHandButton,
.ie7 .bookingGadget .gc_sh .gc_horizontalSh .shortHandButton {

display: block;

margin: 0;

padding: © © 15px;

width: 100%;

border-bottom: 1px solid #d6dbde;
float: none;

}

.bookingGadget .gc_sh .shortHandCheckRates {
background: #5d646a;
font-size: 14px;

font-family: "GothamBook", Helvetica, Arial,

font-weight: normal;
text-align: center;
width: 160px;
height: 26px;
line-height: 26px;
margin: 5px 0 0;
padding: ©;

color: #ffffff;

Verdana, sans-serif;
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We have improved the ability to filter information in the hotel
booking engine by creating a custom URL. The complete
list of supported parameters below:

Mandatory parameters
APl key: &apikey=someApiKey — booking gadget APl key,
this parameter is mandatory. You can get it by navigating to
Setup > External Booking Engine

<div class="'gcBookingGadget'></div>

<script type='text/javascript' src="https://secure.guestcentric.

net/api/bg/?apikey=

&l=default&l=en US'></script>

Default Parameters

- Check-in: today's date

- Check-out: after tomorrow's date
- Number of nights: 2

- Amount (number of rooms): 1

- Number of Adults per room: 1

- Number of Children per room: @

Optional parameters:

Reservation data

- Check-in: &startDay=2012-02-28 — the selection time
frame start day, should be in the yyyy-mm-dd format

- Number of nights: &nrNights=2 — the number of nights
- Amount (number of rooms): &amount=3

- Number of Adults per room: &nrAdults=3

- Number of Children per room: &irChildren=1

https://secure.guestcentric.net/api/bg/book.php?apikey=c3123bde72da365e6e69ea8b7dadb2ca&

1=en



Booking engine display

- Language: &1=[ ca (Catalan), de (German), en (English),

es (Spanish), fi (Finnish), fr (French), it (italian), pl (Polish),
pt (Portuguese), ru (Russian)]

- Preselected offer: &preselect=idofthepreselection

- Filter offers: &hlterOffers=[rooms, promotions, all]

https://secure.guestcentric.net/api/bg/book.phprapikey=c3123bde72da365e6e69ea8b7dadb2ca&
l=en&startDay=2014-08-20

Workflow

- Thank-you page URL: &thankyouUrl=http://someurl.
com — the URL of the page to be shown after the confirmation
screen

- Cancel page URL: &url=http://someurl.com - the URL
to be shown when not completing a booking.

https://secure.guestcentric.net/api/bg/book.php?apikey=c3123bde72da365e6e69ea8b7dadb2ca
&l=en&startDay=2014-08-20

Reporting
- Channel key: &channelKey=someChannelKey — a channel
key that is used for reporting when bookings are completed.

https://secure.guestcentric.net/api/bg/book.php?apikey=c3123bde72da365e6e69ea8b7dadb2ca&
l=en&startDay=2014-08-20

Promo Code
- Promotions: &pc=[ promocode |

Products
- Vouchers: &products=true —1to open products on
Booking Engine.




custom
booking
engine
form

201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
EY)
233
234
235
236
237
238
239
240
241
242
243
244

Custom Booking Engine form

Some examples of websites with a custom booking engine form:

Try it yourself,

<div id="booking”>
<form action=“https://secure.guestcentric.net/api/bg/book.php”
method=“get” accept-charset=“utf-8">
<a href=“best-price-guarantee.html” title=“Club Pollentia****
Best Price Guarantee” class=“why”>.</a>
<div class=“wrapper date”>
<label id=“arrivalDatelLabel” for=“Arrivald”>Check in</
label>
<input type=“text” id=“startDay” name=“startDay”
class=“datep hasDatepicker”>
<!--needs a plugin (eg. http://jgueryui.com/datepicker/)-->
</div>
<div class=“wrapper nights”>
<label id=“numberNightsLabel” for=“NumberN”>Nr. of
nights</label>
<select name=“nrNights” class=“nightSelection”>
<option value=“1”>1</option>
<option value=“2”>2</option> ...
</select>
</div>
<div class=“wrapper adults”>
<label id=“numberAdultsLabel” for=“NumberA”>Adults</
label>
<select name=“nrAdults” class=“adultsSelection”>
<option value=“1”>1</option>
<option value=“2”>2</option> ...
</select>
</div>
<div class=“wrapper adults”>
<label id=“numberChildrenLabel”
for=“NumberC”>Childrens</label>
<select name=“nrChildren” class=“childrenSelection®>
<option value=“1”>1</option>
<option value=“2”>2</option> ...
</select>
</div>
<input type=“hidden” name”apikey” id=“APIlang” value=“f77fbcb
a1896178766403050282bde90”>
<div class=“book”>
<button id=“checkAvailability”>Book Online</button>
</div>
</form>
</div>
</div>
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Wordpress Plug-in

The idea was to create a WordPress plug-in that simplified the
insertion of GuestCentric’s hotel booking engine by using an
easy-to-use widget interface., said Pedro Araujo, author of the booking
engine WordPress plug-in. The installation of the plug-in is extremely
easy. All you need to do is to insert an APl Key that is provided by
GuestCentric, select the type of widget and in less than a minute

a property can have direct online bookings from a WordPress
webpage.

The plug-in opens the door to WordPress designers to create websites
with state of the art technologies for the hotel industry. For the first

time designers can easily offer fully integrated e-commerce facilities on
websites and/or blogs, by installing GuestCentric’s portable booking
engine to promote online bookings.

You should be able to install from the WordPress plugins area.
Optionally:

- Upload guestcentric-booking-gadget.php to the /wp-content/plugins/
directory.

- Activate the plugin through the 'Plugins' menu in WordPress.

- Add the "Booking Gadget" widget in the widgets area.

- Select the options you want.

Visit the WordPress site: http://wordpress.org/plugins/
guestcentric-booking-gadget/

Joomla! - Hotel booking module

The insertion of the module is extremely easy, in a matter of

minutes Joomla! developers can offer their customers a website
with professional online bookings, said Rolando Isidoro, author of the
booking engine module for Joomlal. The module provides freedom to
Joomla! users to customize their booking engine by selecting from

a wide range of languages and layouts. Joomla! users with basic
CSS knowledge can optimize its look and feel by customizing simple
properties like fonts, colors and buttons.
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Joomla module Installation:

step1. download the module from http://forge.joomla.org/gf/
project/guestcentric_bg/frs/.

step2. from the Joomla! Administration screen, select Extensions >
Install/Uninstall.

step3. under Upload Package File, select Browse and select the ZIP
file you downloaded in step1. Then click Upload File & Install.

step4. select Extensions > Module Manager.

step5. locate the GuestCentric booking engine module in the list and
click the module name to set the options.

step6. on the left side parameters insert a custom module name and
choose Yes on the Enable option.

step7. on the right side parameters insert a Booking engine key. If

you have a multi language website enable the option and insert the
correspondent 2 letter ISO country code. Last but not least choose the
layout for this booking engine instance and save your options.




Any question please contact us:
emalil: support@guestcentric.com
phone: (+351) 21 036 0906
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